Forum LAMS for Tech-Heads - General Forum: LAMS and Moodle 2.4.x


58: LAMS and Moodle 2.4.x
In response to 57 01/29/13 09:20 AM
[ Reply | Forward ]
Hi Everyone,

Just wanted to let you know that there's a new version of the LAMS-Moodle plugin for Moodle version 2.4 available here:

If you have any questions, please post here.



Posted by Ernie Ghiglione

59: Re: LAMS and Moodle 2.4.x
In response to 58 04/22/13 04:12 AM
[ Reply | Forward ]
Hi Ernie,

I have tried Moodle 2.4 with LAMS 2.4 following 2.4 integration instructions. Validation gives a success message but when I actually try to add a lesson it gives an error.

Error on Screen is "Call to LAMS failed: received no response or connection was refused. Please check that you have the correct LAMS server URL and that it is online."

Where as error/exception in JBoss logs is
"ERROR org.lamsfoundation.lams.webservice.xml.LearningDesignRepositoryServlet - Problem with LearningDesignRepositoryServlet request
java.lang.ArrayIndexOutOfBoundsException: 1
at org.lamsfoundation.lams.integration.service.IntegrationService.createExtUserUseridMap(

Any idea what I am missing out here ?

Posted by Atif Rasheed

60: Re: Re: LAMS and Moodle 2.4.x
In response to 59 04/22/13 07:12 AM
[ Reply | Forward ]
previously I installed LAMS on same instance (Ubuntu 12) where I had Moodle but now I installed LAMS on windows and it worked. Now sure what went wrong with LAMS instance in Linux.

Posted by Atif Rasheed

Reply to first post on this page
Back to LAMS for Tech-Heads - General Forum